Wireless Connect Logo
Hello Guest! - Login
Contact Wireless Connect
GPRS PCMCIA
Credit Cards Accepted
Back to Table Of Contents >>

How to make a GPRS connection

Description

Let us consider a situation that you are in a place where no internet connection is available, but you have access to your mobile network provider. In this case you can connect MikroTik router to your mobile phone provider using GPRS (General Packet Radio Service) and so establish an internet connection.

Example

  • Plug the GPRS PCMCIA card (with your SIM card) into the router, turn on the router and after it has started, see if a new port has appeared. In this case it is the serial1 port which is our GPRS device:

    [admin@MikroTik] port> print
     # NAME                              USED-BY                          BAUD-RATE
     0 serial0                           Serial Console                   115200
     1 serial1                                                            9600
    [admin@MikroTik] port>
  • Enter the pin code from serial-terminal (in this case, PIN code is 3663) :

    /system serial-terminal serial1
    					
    AT+CPIN=”3663”
    
    

    Now you should see OK on your screen. Wait for about 5 seconds and see if the green led started to blink. Press Ctrl+Q to quit the serial-terminal.

  • Change remote-address in /ppp profile, in this case to 212.93.96.65 (you should obtain it from your mobile network operator):

    /ppp profile set default remote-address=212.93.96.65
  • Add a ppp client:

    /interface ppp-client add dial-command=ATD phone=*99***1# \
    \... modem-init="AT+CGDCONT=1,\"IP\",\"internet\"" port=serial1
  • Now enable the interface and see if it is connected:

    [admin@MikroTik] interface ppp-client> enable 0
    [admin@MikroTik] interface ppp-client> mo 0
        status: dialing...
    
        status: link established
    
           status: authenticated
           uptime: 0s
        idle-time: 0s
    
           status: authenticated
           uptime: 1s
        idle-time: 1s
    
           status: connected
           uptime: 2s
        idle-time: 2s
    [admin@MikroTik] interface ppp-client>

    Check the IP addresses:

    [admin@MikroTik] ip address> print
    Flags: X - disabled, I - invalid, D - dynamic
     #   ADDRESS            NETWORK         BROADCAST       INTERFACE
     0   192.168.0.5/24     192.168.0.0     192.168.0.255   ether1
     1 D 10.40.205.168/32   212.93.96.65    0.0.0.0         ppp-out1
    [admin@MikroTik] ip address>
Back to Table Of Contents >>