Wireless Connect Logo
Hello Guest! - Login
Contact Wireless Connect
Graphing
Credit Cards Accepted
Back to Table Of Contents >>

General Information

Summary

Graphing is a tool which is used for monitoring various RouterOS parameters over a period of time.

Specifications

Packages required: system, routerboard(optional)
License required: Level1
Submenu level: /tool graphing
Hardware usage: Not significant

Description

The Graphing tool can display graphics for:

  • Routerboard health (voltage and temperature)
  • Resource usage (CPU, Memory and Disk usage)
  • Traffic which is passed through interfaces
  • Traffic which is passed through simple queues

Graphing consists of two parts - first part collects information and other part displays data in a Web page. To access the graphics, type http://[Router_IP_address]/graphs/ and choose a graphic to display in your Web browser.

Data from the router is gathered every 5 minutes, but saved on the system drive every store-every time. After rebooting the router, graphing will display information that was last time saved on the disk before the reboot.

RouterOS generates four graphics for each item:

  • "Daily" Graph (5 Minute Average)
  • "Weekly" Graph (30 Minute Average)
  • "Monthly" Graph (2 Hour Average)
  • "Yearly" Graph (1 Day Average)

To access each graphic from a network, specify this network in allow-address parameter for the respective item.

General Options

Submenu level: /tool graphing

Property Description

store-every (5min | hour | 24hours; default: 5min) - how often to store information on system drive

Example

To store information on system drive every hour:

/tool graphing set store-every=hour
[admin@MikroTik] tool graphing> print
    store-every: hour
[admin@MikroTik] tool graphing>

Health Graphing

Submenu level: /tool graphing health

Description

This submenu provides information about RouterBoard's 'health' - voltage and temperature. For this option, you have to install the routerboard package:

Property Description

allow-address (IP address/netmask; default: 0.0.0.0/0) - network which is allowed to view graphs of router healthstore-on-disk (yes | no; default: yes) - whether to store information about traffic on system drive or not. If not, the information will be stored in RAM and will be lost after a reboot

Interface Graphing

Submenu level: /tool graphing interface

Description

Shows how much traffic is passed through an interface over a period of time.

Property Description

allow-address (IP address/netmask; default: 0.0.0.0/0) - network which is allowed to view graphs of router healthinterface (name; default: all) - name of the interface which will be monitoredstore-on-disk (yes | no; default: yes) - whether to store information about traffic on system drive or not. If not, the information will be stored in RAM and will be lost after a reboot

Example

To monitor traffic which is passed through interface ether1 only from local network 192.168.0.0/24, and write information on disk:

[admin@MikroTik] tool graphing interface> add interface=ether1 \
\... allow-address=192.168.0.0/24 store-on-disk=yes
[admin@MikroTik] tool graphing interface> print
Flags: X - disabled
 #   INTERFACE ALLOW-ADDRESS      STORE-ON-DISK
 0   ether1    192.168.0.0/24     yes
[admin@MikroTik] tool graphing interface>

Simple Queue Graphing

Submenu level: /tool graphing queue

Description

In this submenu you can specify a queue from the /queue simple list to make a graphic for it.

Property Description

allow-address (IP address/netmask; default: 0.0.0.0/0) - network which is allowed to view graphs of router healthallow-target (yes | no; default: yes) - whether to allow access to web graphing from IP range that is specified in /queue simple target-address simple-queue (name; default: all) - name of simple queue which will be monitoredstore-on-disk (yes | no; default: yes) - whether to store information about traffic on hard drive or not. If not, the information will be stored in RAM and will be lost after a reboot

Example

Add a simple queue to Grapher list with simple-queue name queue1, allow limited clients to access Grapher from web, store information about traffic on disk:

[admin@MikroTik] tool graphing queue> add simple-queue=queue1 allow-address=yes \
\... store-on-disk=yes

Resource Graphing

Submenu level: /tool graphing resource

Description

Provides with router resource usage information over a period of time:

  • CPU usage
  • Memory usage
  • Disk usage

Property Description

allow-address (IP address/netmask; default: 0.0.0.0/0) - network which is allowed to view graphs of router healthstore-on-disk (yes | no; default: yes) - whether to store information about traffic on hard drive or not. If not, the information will be stored in RAM and will be lost after a reboot

Example

Add IP range 192.168.0.0/24 from which users are allowed to monitor Grapher's resource usage:

[admin@MikroTik] tool graphing resource> add allow-address=192.168.0.0/24 \
\... store-on-disk=yes
[admin@MikroTik] tool graphing resource> print
Flags: X - disabled
 #   ALLOW-ADDRESS      STORE-ON-DISK
 0   192.168.0.0/24     yes
[admin@MikroTik] tool graphing resource>
Back to Table Of Contents >>