Wireless Connect Logo
Hello Guest! - Login
Contact Wireless Connect
Xpeed SDSL
Credit Cards Accepted
Back to Table Of Contents >>

General Information

Summary

The MikroTik RouterOS supports the Xpeed 300 SDSL PCI Adapter hardware with speeds up to 2.32Mbps. This device can operate either using Frame Relay or PPP type of connection. SDSL (Single-line Digital Subscriber Line or Symmetric Digital Subscriber Line) stands for the type of DSL that uses only one of the two cable pairs for transmission. SDSL allows residential or small office users to share the same telephone for data transmission and voice or fax telephony.

Specifications

Packages required: synchronous
License required: Level4
Submenu level: /interface xpeed
Standards and Technologies: PPP (RFC 1661), Frame Relay (RFC 1490)
Hardware usage: Not significant

Additional Resources

Xpeed Interface Configuration

Submenu level: /interface xpeed

Property Description

arp (disabled | enabled | proxy-arp | reply-only; default: enabled) - Address Resolution Protocol

disabled - the interface will not use ARP protocol
enabled - the interface will use ARP protocol
proxy-arp - the interface will be an ARP proxy
reply-only - the interface will only reply to the requests originated to its own IP addresses, but neighbor MAC addresses will be gathered from /ip arp statically set table only

bridged-ethernet (yes | no; default: yes) - if the adapter operates in bridged Ethernet modecr (0 | 2; default: 0) - a special mask value to be used when speaking with certain buggy vendor equipment. Can be 0 or 2dlci (integer; default: 16) - defines the DLCI to be used for the local interface. The DLCI field identifies which logical circuit the data travels overlmi-mode (off | line-termination | network-termination | network-termination-bidirectional; default: off) - defines how the card will perform LMI protocol negotiation

off - no LMI will be used
line-termination - LMI will operate in LT (Line Termination) mode
network-termination - LMI will operate in NT (Network Termination) mode
network-termination-bidirectional - LMI will operate in bidirectional NT mode

mac-address (MAC address) - MAC address of the cardmode (network-termination | line-termination; default: line-termination) - interface mode, either line termination (LT) or network termination (NT)mtu (integer; default: 1500) - Maximum Transmission Unitname (name) - interface namesdsl-invert (yes | no; default: no) - whether the clock is phase inverted with respect to the Transmitted Data interchange circuit. This configuration option is useful when long cable lengths between the Termination Unit and the DTE are causing data errorssdsl-speed (integer; default: 2320) - SDSL connection speedsdsl-swap (yes | no; default: no) - whether or not the Xpeed 300 SDSL Adapter performs bit swapping. Bit swapping can maximize error performance by attempting to maintain an acceptable margin for each bin by equalizing the margin across all bins through bit reallocation

Example

To enable interface:

[admin@r1] interface> print
Flags: X - disabled, R - running, D - dynamic, S - slave 
 #    NAME                                              TYPE             MTU
 0 R  outer                                             ether            1500
 1 R  inner                                             ether            1500
 2 X  xpeed1                                            xpeed            1500
[admin@r1] interface> enable 2
[admin@r1] interface> print
Flags: X - disabled, R - running, D - dynamic, S - slave 
 #    NAME                                              TYPE             MTU
 0 R  outer                                             ether            1500
 1 R  inner                                             ether            1500
 2 R  xpeed1                                            xpeed            1500
[admin@r1] interface>

Frame Relay Configuration Examples

MikroTik Router to MikroTik Router

Consider the following network setup with MikroTik router connected via SDSL line using Xpeed interface to another MikroTik router with Xpeed 300 SDSL adapter. SDSL line can refer a common patch cable included with the Xpeed 300 SDSL adapter (such a connection is called Back-to-Back). Lets name the first router r1 and the second r2.

Router r1 setup

The following setup is identical to one in the first example:

[admin@r1] ip address> add inter=xpeed1 address 1.1.1.1/24
[admin@r1] ip address> print
Flags: X - disabled, I - invalid, D - dynamic
  #   ADDRESS            NETWORK         BROADCAST       INTERFACE
  0   1.1.1.1/24         1.1.1.0         1.1.1.255       xpeed1

[admin@r1] interface xpeed> print
Flags: X - disabled
  0   name="xpeed1" mtu=1500 mac-address=00:05:7A:00:00:08 arp=enabled
      mode=network-termination sdsl-speed=2320 sdsl-invert=no sdsl-swap=no
      bridged-ethernet=yes dlci=16 lmi-mode=off cr=0
[admin@r1] interface xpeed>

Router r2 setup

First, we need to add a suitable IP address:

[admin@r2] ip address> add inter=xpeed1 address 1.1.1.2/24
[admin@r2] ip address> pri
Flags: X - disabled, I - invalid, D - dynamic
  #   ADDRESS            NETWORK         BROADCAST       INTERFACE
  0   1.1.1.2/24         1.1.1.0         1.1.1.255       xpeed1

Then, some changes in xpeed interface configuration should be done:

[admin@r2] interface xpeed> print
Flags: X - disabled
  0   name="xpeed1" mtu=1500 mac-address=00:05:7A:00:00:08 arp=enabled
      mode=network-termination sdsl-speed=2320 sdsl-invert=no sdsl-swap=no
      bridged-ethernet=yes dlci=16 lmi-mode=off cr=0
[admin@r2] interface xpeed> set 0 mode=line-termination
[admin@r2] interface xpeed>

Now r1 and r2 can ping each other.

MikroTik Router to Cisco Router

Let us consider the following network setup with MikroTik Router with Xpeed interface connected to a leased line with a CISCO router at the other end.

MikroTik router setup:

[admin@r1] ip address> add inter=xpeed1 address 1.1.1.1/24
[admin@r1] ip address> print
Flags: X - disabled, I - invalid, D - dynamic
  #   ADDRESS            NETWORK         BROADCAST       INTERFACE
  0   1.1.1.1/24         1.1.1.0         1.1.1.255       xpeed1

[admin@r1] interface xpeed> print
Flags: X - disabled
  0   name="xpeed1" mtu=1500 mac-address=00:05:7A:00:00:08 arp=enabled
      mode=network-termination sdsl-speed=2320 sdsl-invert=no sdsl-swap=no
      bridged-ethernet=yes dlci=42 lmi-mode=off cr=0
[admin@r1] interface xpeed>

Cisco router setup

CISCO# show running-config
Building configuration...
Current configuration...

...
!
ip subnet-zero
no ip domain-lookup
frame-relay switching
!
interface Ethernet0
 description connected to EthernetLAN
 ip address 10.0.0.254 255.255.255.0
!
interface Serial0
 description connected to Internet
 no ip address
 encapsulation frame-relay IETF
 serial restart-delay 1
 frame-relay lmi-type ansi
 frame-relay intf-type dce
!
interface Serial0.1 point-to-point
 ip address 1.1.1.2 255.255.255.0
 no arp frame-relay
 frame-relay interface-dlci 42
!
...
end.

Send ping to MikroTik router

CISCO#ping 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/31/32 ms
CISCO#

Troubleshooting

Description

  • I tried to connect two routers as shown in MT-to-MT, but nothing happens

    The link indicators on both cards must be on. If it's not, check the cable or interface configuration. One adapter should use LT mode and the other NT mode. You can also change sdsl-swap and sdsl-invert parameters on the router running LT mode if you have a very long line

Back to Table Of Contents >>